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HOW TO GRAPH SALES IN EXCEL 
 

By Kathleen Bryce, Real Estate Appraiser, Fort Myers, Fla. 
 And initially posted on www.AppraisalScoop.com 

Edited and Revised for the East Bay (CA) Paragon MLS by Richard Betts and Hardeep Luthra 
 

 
 

I. INTRODUCTION 
 
It has been said that a picture can say a thousand words.  This is especially true when that picture reflects what the 
value trend in the marketplace is doing.  With the markets across the nation in transition, it is more important than 
ever to be able to relay to our clients exactly what the market is doing.  One of the best methods of understanding 
complex ideas such as market trends is to demonstrate them with pictures - pictures that tell a story.  Using very 
simple calculations within a spreadsheet programs, these pictures can be easily presented to your clients in the 
form of a simple chart.  This is a rather simple process, yet provides very dramatic results.   
 
The following steps will walk you through creating a chart from raw market data.  This document is not intended to 
teach basic Excel procedures and assumes the reader knows the basics.  For basic Excel training, Microsoft offers 
excellent training articles.  http://office.microsoft.com/en-us/training/default.aspx  Also, please note that this article 
emphasizes the steps, rather than the data.  We start off with illustrations from the East Bay (CA) Paragon 
MLS, and then switch to Excel illustrations from the original article that are using data in Florida. 
  

II. SELECTING THE DATA 
 
The first step is to select the data to be analyzed – an important step.  Most of the time, you will want to analyze the 
sales price trend for a specific property.  You will want to select sold properties that are similar to the subject 
property.  It is important to try to select properties that bracket the subject property.  Based on your assignment 
problem and the scope of work you have selected, you may want to graph an entire zip code, or perhaps just a 
narrow range of the neighborhood.  And to get a good sense of the changes over time, you will want at least two 
years of sales, and possibly three!  For a graph, you usually will want to select at least 100 sales, or more, in order 
to have enough data to get a reasonably reliable trend line (discussed below).  But collecting too many sales may 
mean that some sales are too different from the subject property.  You might also want to analyze Expired and 
Withdrawn listings over the past year, perhaps, or maybe also Current Listings.  For now, we will just talk about 
sales.  
 
Data selection and downloading steps for this demonstration are shown for the Paragon 4 MLS system.  Each data 
provider will differ in how you select data, and how you export a data file to your computer.  If you have questions or 
problems with selecting or exporting, contact customer support at your data vendor! 
 
Next, what information about the sales should be selected?  In part, this will depend on how easy it is to download 
information from your data provider!  At the very least, the date of sale, sale amount, and gross living area (GLA) 
must be obtained.  This allows you to convert sale price to price per square foot ($/sf), and graph it versus time, to 
see how it has changed.  The address or MLS number or Assessors parcel number should also be obtained, so that 
you can know which sale is which, later on.  Generally, however, it is better to select all of the data that you can get 
on each sale, and sort it out after you download it, as we will show you, below. 
 
For this demonstration, we had selected a market that has a noticeable downward price trend, N. E. Richmond, in 
Contra Costa County, Ca.  (The graph of those sales is not presented in this online article.)  The average home in 
this neighborhood is an older two bedroom home.  Most have one bathroom, between 700 and 1200 square feet of 
living space, and a one car garage.  The search was for all two-bedroom sales in this district within the past three 
years.  The selection screen is shown in Figure 1.  The particular neighborhood is a specific location in this MLS, so 
only the location code needs to be used.  

http://www.appraisalscoop.com/
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FIGURE 1: THE PARAGON DATA SELECTION SCREEN. 
 
 
After entering your selection criteria, click the blue “Count” button, to the upper right, to see how many sales meet 
your criteria.  If you have too few sales, consider widening your selected geographic and/or property characteristics 
and recounting.  If you have over 250 or 300 sales, consider tightening your characteristics and recounting.  When 
you are ready, select the report type in the “Available Reports” pull-down list just under the “Count” button.  We 
have used “Default MLS Defined Spreadsheet.”  Next, click on the green “Search” button.  The MLS system will 
select the sales that meet the criteria, and display them in a table or spreadsheet view, shown in Figure 2. 
 
 

 
 

FIGURE 2: THE PARAGON “DEFAULT MLS SPREADSHEET” SCREEN. 
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III.   EXPORTING THE DATA 
 
The process for exporting data is different for each data vendor.  Most data vendors may have more than one way 
to export data.  For example, Paragon has an “Export” button (in blue) in the second row top center.  This can be 
used to convert the data to a “Comma Delimited” format (*.csv), which is the preferred format for moving data into 
Excel or another spreadsheet program from some other source.  If you use this option, save the file on your 
computer, open Excel, click “File>Import”, navigate to where you saved the *.csv file, and follow the Text Import 
Wizard in Excel to open and convert the file. 
 
However, Paragon 4 has a much easier method for you to use!  In the “Available Reports” column at the right, there 
is a bar in the middle of the column labeled “Specialty Views”.  Click on this bar to show the alternatives under this 
heading, and then click on “Excel”.  The Paragon computer will process your data and show it to you in an Excel 
spreadsheet, but still within Paragon.   The table now has an Excel toolbar at the top, and one button in the center 

of this new toolbar looks like this: .  See Figure 3, below.  Click on this button, wait, and the data file is 
automatically exported to your computer and opened in your own Excel program  
 
 

 
 

 
FIGURE 3: THE PARAGON “EXCEL TABLE” SCREEN. 
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IV. CLEANING UP THE DATA 
 
When first opened in Microsoft Excel, the data appears as shown in Figure 4, (using Excel 2003).  At this point, we 
switch to the Florida data, so as to reuse Kat’s excellent illustrations. 
 
 

 
 

FIGURE 4: THE OPEN FILE IN EXCEL. 
 
At the top of this window in Excel, depending on how you imported the data, the file name might have punctuation 
marks and end in “.csv”.  If so, the file name must first be changed to an Excel format before any charts may be 
created.  In any case, now is a good time to save the file!  Select “File > Save As” from the menu.  In the “Save as 
Type” pull-down box at the bottom of the window, be sure to select “Microsoft Excel Workbook (.xls)”.   Give the 
worksheet an appropriate name, and click “Save”.  See Figure 5. 
 
 

 
 

FIGURE 5: THE “SAVE AS” SCREEN. 
 
 
Next, again depending on how you downloaded the data, you may need to rename the worksheet tab name, to 
remove any punctuation marks.  To rename the sheet, double-click on the sheet tab, which is labeled 
“.csv]9209705_RESI_FE4[1]” in the illustration below.  You may now change the name.  In this demonstration, the 
sheet tab is renamed "Raw," because it contains the raw downloaded data.  Type in the new name and press 
“Enter”. 
  
Next, it is good practice to create a copy of this raw data on the next sheet.  This new sheet will be used for all 
calculations, thereby preserving the initial search download, intact, on the “raw” page.  To do this, right mouse-click 
on the tab labeled "raw" at the bottom of this sheet.  Select "Move or Copy" from the menu, then select "(move to 
end)" from the menu, and check the "Create a Copy" checkbox.  Click OK, as shown on Figure 6. 
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FIGURE 6: THE “MOVE OR COPY” SHEET SCREEN. 
 
 
A new sheet is created with a carbon copy of the data and it is named "Raw (2)".  Rename this new sheet to 
"Cleaned" by first selecting this tab, then double clicking the name.  Change the name to “Cleaned” and press 
Enter.  
  
Now is the time to clean up the data.  First, consider shrinking the cell widths, to try and get the whole table width 
visible on the screen at once.  To narrow a particular column, place the cursor on the line at the right side of the 
column heading, (a “left-right arrow” should appear), hold down the left mouse-button, and drag the divider bar to 
the left.  Note that you might want to completely close or shrink some columns that may not be important, such as 
the city, (since you know what city these sales are all in)!  You can also delete any columns that are completely 
useless.  Just place your cursor on the bar at the top of the column in question, right click, and select “delete”.  
However, as a general rule, be slow to delete columns, as you may later change your mind and want that column 
for some reason!   (Remember that detailed help with Excel can be found at the website mentioned on page 1.) 
 
The second step is to review the sales data, to see if any of the sales are too different from the subject property to 
be left in the analysis.  Since we only used location and bedroom count to do this sort, perhaps you should check lot 
size, to see if there is a sale with a double lot.  Or perhaps there is a sale of a brand-new home, which would be 
very different from the typical houses in this neighborhood!  Remove any sales records that don't fit the model that 
you intended.  Since you have kept all of the raw data on the “Raw” tab, you could delete these sales on the 
“Cleaned” tab: right-click on the row number for the sale you want to delete, and then select “Delete.” 
 
You will now have something that looks like Figure 7, which follows.  Note the two Sheet tabs at the bottom left, 
named “Raw” and “Cleaned”. 
 
 

 
  

FIGURE 7: EXCEL TABLE, WITH RENAMED TABS. 
 
 
 

 
IV. PREPARING THE DATA TO MAKE THE GRAPH 

 5



 
You must decide what you want to graph.  We believe that, to examine what is happening to sales prices over time, 
nothing beats calculating sales based on $/Sq.Ft. versus time!  But there are other aspects of the sales that you 
might want to analyze, such as price per sq. ft. versus size: How does price per sq. ft. change with building size?  
Or price per sq. ft. versus age?  Or homes in the east half of the neighborhood versus those in the west half?  Or 
Days on Market versus time?  Or number of sales per month? All of these, and a lot more, can be graphed! 
 
So, we want to make a graph that shows the date on the bottom, the “horizontal axis” or “X axis”, and price per sq. 
ft. on the “vertical “or “Y” axis.  First, we need to insert a column in which to calculate the price per sq. ft.  We’ll call it 
“$/SF”.   It makes the charting process much simpler if the $/SF column is immediately to the right of the "date of 
sale" column.   To do this, select the letter associated with the field immediately to the right of the field that contains 
the date of sale column on the spreadsheet.  This is column E on figure 7, above.  This will highlight that entire 
column.  Type “Cntrl+” (“Control” plus the “+” sign), or select “Insert > Column” from the menu. 
  
Move to the first cell at the top in this newly created column.  Type the label name for this new column.  For the 
example, it is “$/SF”, and then press “Enter”.  You should now be in the first empty row below this new name.  Type 
"=" (the equal sign), then select the cell that contains your sale price, type "/" for divide, and then select the cell that 
contains the GLA.  These steps should create the formula to calculate price per sq. ft.  The formula is “=F2/J2” in 
the example. Press “Enter”.  This cell should now contain your first row’s sold price in $/SF.  If it does, you’re 90% 
there!  See Figure 8. 
 

 
 

FIGURE 8: EXCEL TABLE, WITH FORMULA IN CELL E2. 
  
 
Oops… After you press “Enter,” does your formula look like a date?  To format that column as a number, first select 
the column.  Next, select “Format > Cells” from the menu.  Finally, select “Number” from the pop-up window. 
  
To copy this formula to the rest of the cells in the column, double-click on the lower right hand corner of the box that 
surrounds this new formula.  There is a funny little box in that corner (see yellow arrow below).  When the little box 
is double-clicked, Excel will copy this formula down the column for the rest of the spreadsheet.  It will stop at the first 
blank row it comes to.  So, double click on the lower right corner box, as pointed out by the arrow in Figure 9. 
 
 

 
 

FIGURE 9: EXCEL TABLE – THE “BOX” TO COPY A FORMULA. 
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The formula is copied to the last row in the column, and a $/sf is calculated for each sale, shown in Figure 10. 



 
  

 
 

FIGURE 10: EXCEL TABLE – WITH THE FORMULA COPIED. 
 
 
With Paragon, your file may have just the listing date, but not the sale date!  However, it probably also has “Days on 
Market.”  Decide where your sale date column needs to be, just to the left of your “$/SF” column, and insert a 
column there. Label it “Sale Date.”  In the second cell down, type in “+” then click on the listing date, then click “+” 
and then the Days on Market. Click “Enter” to get the sale date! Copy the formula down the rest of the column. 
 
It’s nice to have the data sorted by the date sold.  As you can see in the example above, the dates are not in order.  
To sort on the date field, first type “Cntrl A,” to select the entire spreadsheet.  Then, from the menu, select “Data > 
Sort”.  The “Sort” menu will open, as shown in Figure 11, below.  First, select the "Header row" radio button, near 
the bottom of this menu.  Select from the "Sort by" drop list the field name that has the sales date.  It is “Selling 
Date” in the example. Select the corresponding "Ascending" Radio button and click "OK." 
 
 

  
 

FIGURE 11: EXCEL TABLE – SORT MENU SCREEN. 
 
 
Hopefully, you now have a worksheet with your data sorted by date of sale and the $/SF calculated for each row, as 
shown on Figure 12, below.  If the sort did not work, you might want to select the date column, place your cursor on 
the top cell, right-click, and select “Format cells”.  Under the “Number” tab, select “date” and then “OK”.  Then, retry 
the “sort” steps.  You might even have to reformat each cell individually!  Now is a good time to save your work 
again.  Select “File > Save” from the menu. 
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FIGURE 12: EXCEL TABLE: AFTER SORTING BY SALE DATE. 
 
 
VI.  PREPARING THE TABLE OR CHART 
 
Now you are ready to chart!  The first step is to indicate the data to be charted or graphed.  Select the cells that 
contain the data both for the date of sale, "Sale Date" in the example, and "S/Sq.Ft."  This may be done by dragging 
the mouse from the first cell of the first column of graph data to the bitter end on the second column, last cell.  A 
quicker way is to select the top row cell that contains the label "Selling Date", (or whatever your export named it).  
Next, click “Cntrl Shift ↓” (down arrow), all three of these at once. Then, release all keys.  Now, hold down the 
“Shift” key and press the “right arrow key”. You should now have highlighted all of the sale date and $/Sq.Ft. 
columns, shown in Figure 13, below.   If that didn’t work for you, use your mouse to select these two columns. 
 
 

 
 

FIGURE 13: EXCEL TABLE, WITH BOTH COLUMNS OF DATA SELECTED. 
 
 

Next, there should be an Icon on the top menu that looks like a bar chart.  It should look like this:    Clicking on 
this icon button will open the Chart Wizard.  Or you can select “Insert > Chart” from the menu. 
  
The Chart Wizard will open, shown in Figure 14, below.  Under the “Standard Types” tab, select "XY (Scatter)" from 
the left window.  Note that this screen is labeled “Step 1 of 4.” 
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FIGURE 14: THE CHART WIZARD, STEP ONE, “STANDARD TYPES” TAB. 
 
Select “Next” at the bottom of the Step 1 screen.  You do not have to enter anything in Step 2, as you have already 
defined the data, so just select “Next”.  In the “Step 3 of 4 – Chart Options” screen, select the “Title” tab, and in the 
“Chart Title” box, type a name for this chart.  We used “Sales Trends at $/Sq. Ft.”   This screen is shown in Figure 
15, below. 
 

 
 

FIGURE 15: “TITLE” TAB OF THE CHART WIZARD, “STEP 3 OF 4”. 
 
 
Still in the “Step 3 of 4” screen, select the “Legend” tab, and then select the "Top" Radio Button from the choices on 
the left.  Click “Next,” and then in Step 4, click “Place chart as: New Sheet.”  This will place your chart on a separate 
sheet, with its own tab, rather than at the bottom of your sales table.  This is much more convenient if you want to 
quickly find and print the chart or table.  Finally, click “Finish”.  Tada!!!  Here's your chart (Figure 16)! 
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Sales trends at $/Sq.Ft.
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  FIGURE 16: GRAPH OF “SALES TRENDS AT $/SQ. FT.” 
 
 
This is a pretty basic graph!  Next, we want to add a Trendline, which is a major help in interpreting the data.  And 
we can improve the formatting of the chart, to make it easier to read, and more attractive, if needed!  To add a 
Trendline, right mouse-click on any one of the 'dots' (data points) on your chart.  From the menu that pops up 
(shown in Figure 17 below, select "Add Trendline".  
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       FIGURE 17: DATA POINTS “RIGHT-CLICK” SELECTION MENU. 



 
 
The “Add Trendline” menu will appear, shown in Figure 18, below.  From the menu, select the “Type” tab and then 
select “Polynomial”.  In the right “Order” counter, change the “Order” to 3.  Press “OK”. 
 
 

 
  

FIGURE 18: “ADD TRENDLINE” SCREEN. 
 
Your chart should now look like Figure 19.  It is desirable to experiment with different orders of “Polynomial” graph, 
to see how the Trendline changes, and which appears to best match the pattern of the sales.  A “two” will straighten 
the graph compared to a “three,” while a “four” will make the curves greater.  The “Linear” also can match the 
pattern of the sales, in cases where the change is relatively constant over time. 
  

 
 
FIGURE 19: SCATTERPLOT GRAPH WITH POLYNOMIAL TREND LINE. 
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There are several things that you can do to make the chart clearer.  Generally, these are changes to some of the 
formatting.  To make the “Date of Sale” information easier to understand, right mouse-click over any one of the 
dates and select “Format Axis”.  A menu will load to allow you to change how the numbers are formatted and the 
scale.   Select the “Number” tab, and from the right window pane, select the format of “Mar-01”.  Next, select the 
“Scale” tab.  Change the “Major Unit” to a value that will allow some readability.  For this axis, the major unit is in 
days, so select 60 days.  Also set the “Minor Unit” to “15”.  Verify that the “Auto” boxes to the left of the “Major Unit” 
and “Minor Unit” cells are not checked.  Finally, click on “OK” to close the formatting screen. 
 
A right-click near the top in an open space on your chart brings up a menu that gives you numerous options for 
further formatting your chart.  One option is “Format Chart Area”, which brings up a menu that allows you to change 
the border, or the color of the graph body. Another selection is “Chart Options”, which offers the ability to change 
the titles, the axes, the gridlines, the legend or the data labels.  
 
In Figure 20, below, the vertical (Y-Axis) scale was changed to expand the curve, the colors of the chart and 
trendline were changed and the trendline was change to a polynomial order-4. 
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 FIGURE 20: THE FINAL GRAPH. 
 
 
As you can see, the formatting options are endless. 
 
The final step is to insert the chart in your report.  Just “right mouse-click” the graph in a clear area in the center, 
select “Copy”, right-click in your report, and select “Paste”!   There is nothing like a chart to clearly show factual 
evidence as to what the current market conditions are!    
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